Mac技巧之旧MacOS系统上运行苹果iPhone SDK的方法

分类:Mac
2008-4-28 01:09

评论(0)
阅读(5457)

Tags: , ,
用苹果SDK可以为iPhone手机开发手机软件。但是很多苹果fans用的是旧苹果电脑,运行的也是旧MacOS系统。如何在旧的旧MacOS系统上运行苹果iPhone SDK呢?下面是旧MacOS系统上运行苹果iPhone SDK的方法

     1.一旦你已经在你的手机上安装了可以安装的软件包,返回DMG,找到文件包。

  2.你可以在上方看到Aspen包,双击安装它。

  3.此时在你手机上的Default Installation Directory上就会有个Platforms Folder,它可能在你的硬盘的root内。查看下确定它真的在那里。

  4.与iPhone SDK 有关的全部东西都在Platforms Folder里,现在把这些都放在Developer directory下的/Developer/Platforms/folder里。

  5.重新运行Xcode(如果你手机开机的话),这时你就可以自由选择在你的手机里安装软件了,同时你还可以用AspenSimulator测试Code。

  到目前为止我没有遇到什么特殊情况出现,除了在安装时遇到了一次警告,因为目标不匹配(PPC vs.i386),但是这也在意料之内。当然我不知道如果你给苹果公司付了99美元得到认证之后是否它就可以正常运行了,到目前我只是将它作为开发环境,并且我打算在6月AppStore发布时再将SDK和Intel Box一起运用。不管怎样,现在已经可以在iBook上运行Leopard了。并且,效果相当好.

  
  
发表评论
  
       昵称   [注册]    密码   游客无需密码   
         
    打开HTML     打开UBB     打开表情     隐藏           记住我